Symptom
- When few Hiring manager clicks on the New Hire Activities under onboarding; the screen shows an error message "An error has occurred while trying to process your request. If the problem persists, please contact our technical support. "An application error occurred. Please try again later, or notify support
Environment
ONB; SF Onboarding
Cause
One of the cause could be : Corrupt or blank data in Onboarding Candidate Info Object
We can verify it by doing the following
1. Create an Adhoc Report with name "ONB Test"
2. Select the columns: CandidateApplicantID, CandidateManagerId, CandidateUserId, CandidateFirstName, CandidateLastName, UserFirstName, UserLastName
3. Sort result by CandidateManagerId
4. Execute the report by clicking Preview
5. Check the affected hiring manager id in the report . Review the values in that row.
Resolution
To resolve this issue, please delete the record of the blank value candidate from Onboarding candidate Info object (Admin center -> Manage Data -> OnboardingCandidateInfoObject -> Candidate name.
Keywords
New hire Activities; Hiring Manager activity; , KBA , LOD-SF-OBD , Onboarding , Problem