Symptom
When a Canvas or ORD report is exported to CSV or Excel via the Export icon in the page, the resulting file shows a different output or number of records compared to the one seen on the user's screen.
User observes data discrepancy but expects the output to be exactly the same.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors People Analytics
- Canvas / Online Report Designer
Reproducing the Issue
- Go to Reprt Center and preview the Canvas report
- Set the Runtime filters
- Click on "Done"
4. Export the file to Excel using the green icon at the left-hand corner
5. Wait for the report to be on green light in Report Distributor Downloads
6. Once the report is ready, download the report
7. Open the report
Cause
Exporting the file to Excel using the green icon means exporting the report offline. Thus, the runtime filters that was set up before previewing the file online was not being taken into consideration. Only the filters inside the query (Manage filters) are being respected causing the output in online preview mode and Excel file to be inconsistent.
Resolution
Instead of exporting the file using the green icon (which is offline), we should export the file using the options available at the right-hand side of the page if we want the runtime filters to be respected by the report as well.
Keywords
- inconsistent records, data discrepancy, incorrect values, canvas export offline, run offline, run online result