Symptom
Fields created by Key User Tool (KUT) cannot be set as mandatory for the Ticket Product List Preview.
Reproducing the Issue
Prerequisite: KUT field(s) were created in the system, example field 123 (123 represents the field name.
- Go to the Service work centre.
- Go to the Tickets view.
- Open the relevant Ticket ABC (ABC represents the Ticket name).
- Enter the Adaptation mode.
- Select Edit Master Layout.
- Go to the Products facet.
- Add the field 123.
- For 123 click Change Properties.
RESULT: There is no option to set the field as Mandatory.
Cause
It is not possible to set any fields as Mandatory which are under the preview pane using KUT.
This is implemented to maintain the consistency of the list data.
Resolution
This is expected system behaviour.
Keywords
KBA , LOD-CRM-SRP , Service Request Processing , How To
Product
SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1708