Symptom
Property rules cannot be used to set the value of a field based on the created rule.
Reproducing the Issue
We will use Individual Customer as example.
Prerequisites:
You have already created an extension field on an individual customer header level.
- Go to the Customers work centre.
- Select the Individual Customers view.
- Open a random individual customer.
- Enter Adapt mode.
- Select the Properties icon of the already created extension field.
- Click the Rule hyperlink.
- You set up a function and expect the value to be displayed in the field.
- No value is displayed in the extension field.
Cause
This is expected system behaviour.
Resolution
Property rules cannot be used for setting a value based on the set up function/rule.
The rules are meant to set dynamic properties of the field like visibility, read only and mandatory
Keywords
KBA , LOD-CRM-ACC , Account , How To
Product
SAP Cloud for Customer core applications 1611 (old) ; SAP Cloud for Customer core applications 1708 (old) ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1708