Symptom
You require to upload E-mails to the Open Leads in the system. While migrating using the activity Migration of E-mail Activities, you receive the below error:
BusinessPartnerInternalID XXXXXX is Not Valid
Reproducing the Issue
- Go to Business Configuration work center
- Select Implementation Projects view or Overview
- Search and Open the activity Migration of E-mail Activities
- Choose Migrate E-mail Activities using the migration tool
- Execute Migration for the respective Migration file with Migration Mode Add new records
- You receive the error message mentioned during the Simulation step
Cause
The Lead has a Contact XXXXXX created which is In Preparation status. When the Contact XXXXXX is not Active in the system, it cannot be used in the Sender field in the Migration template. Further, as the Contact XXXXXX is not Activated, it will not be available in the Contacts OWL in the system.
Resolution
To upload E-mail Activities to Open Leads with Inactive Contacts is a new requirement.
We have added this functionality as a new requirement and will be available in one of the future releases.
Keywords
Email Activities; Contacts , KBA , SRD-CC-FED , Feeds , How To