Symptom
The content was successfully imported using the Learning Import Content tool, however, when attempting to launch the course, "404 - File or directory not found” and/or “404 Not Found” messages appear.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Search for the desired course and access it >
- Attempt to launch the content >
- The "404 Not Found" error is observed.
Cause
There are different possible causes:
- The "directory" is missing from the URL prefix.
- An additional space is added during content import at the end of the URL field in the 'Deployment Location'.
- There's a special character in the content object ID.
- There's an incorrect backend configuration.
Resolution
Please, review the information provided for each of the potential causes:
1. Check the "Directory" field. Steps: System Administration > Configuration > Content Deployment Locations > Search and edit the impacted deployment location ID) >
-
- The "Directory" field specifies which directory the content will be uploaded to on the content server (iContent).
- The "URL Prefix" field specifies the launch path for the content.
- The "URL Prefix" field must contain the directory as well.
2. Remove the additional blank space after the folder name in the filename. Steps: Content > Content Objects > Search and edit the "Launch Method" tab of impacted content object) >
3. Don't use special characters including ';' or '.' or ',' or '-' or spaces in the "Content Object ID" when setting them up. For additional information about special characters, please, review KBA 2768097. Import the content again, creating a new ID without special characters.
4. Check iContent folder structure path.
-
- Confirm the folder path inside iContent server is correct by logging in to the iContent account.
- Keep in mind that the Content Object Filename is divided in 2 parts: Prefixes and Suffixes (iContent Folder Path).
- Prefixes will vary based on the system's datacenter (KBA 2396085).
- Suffixes will always vary.
- Suffixes will always start after prefix part "self-managed/". Everything after the "self-managed/" is related to the iContent folder structure.
In this scenario, the iContent folder structure is: LMS/Prod_Content/Compliance/index.html.
- Content Object Filename must be: "prefix" + "/LMS/Prod_Content/Compliance/index.html" (e.g. /learning/user/onlineaccess/icontent.do?Course=CUSTOM&url=/self-managed/LMS/Prod_Content/Compliance/index.html)
- Kindly see folder structure below after successfully logging into the iContent account.
Example scenario 1: If the folder structure and/or "index" file does not exist inside the iContent account, that's why the 404 is being thrown.
- To resolve this, create the exact folder structure based on the content object's filename or set up a new folder structure and change it in the content object's filename.
Example scenario 2: If the folder structure exists but there are some divergence in the path (additional folders, index file or folder are named differently, etc.), that's why the 404 is thrown.
- To resolve this, include the additional folders inside iContent folder structure or adjust the content object's filename to match what's inside iContent folder structure.
If all of the above is checked and there are still issues, the backend configuration could be incorrect. Contact SAP Support providing tracing logs (or support access to obtain tracing logs (KBA 2088892)), so additional checks can be performed.
IMPORTANT: Embedded SKU Learning demo tenants typically follow the naming convention of the production tenant, with an additional "ES" (Embedded SKU) appended to the name. For regular tenants, "ES" shouldn't be included in the iContent account name. As a general recommendation, if both iContent SFTP users exist (prod. and "ES"), then the prod. tenant should use the prod. (non "ES") iContent SFTP user and the embedded demo tenant should use the "ES" iContent SFTP user. Don't mix embedded SKU Learning tenants and iContent SFTP users with regular (prod., stage, preview, etc.) Learning tenants and iContent SFTP users.
Note:
- "My folders" folder isn't considered for this set up.
- Take into consideration that SAP doesn't hold any self-managed customer iContent credentials. Even though SAP provide the accounts to customers, it's the customer's responsibility to maintain it.
- If nothing wrong is found after concluding all the checks, verify if the content holds one or more files with the size over 1800 MB (~1.8 GB). Files bigger than 1800 MB (~1.8 GB) aren't supported and will result in the "404 File or Directory not found". Check the KBAs 3165280 and 2318240 for additional details about it.
- SAP Support, please, refer to the internal memo for more details.
See Also
Keywords
learning, error, course, launch, issue, 404, not, found, icontent, server, es, deployment, location, configuration, url, prefix, mismatch, content, object, filename, folder, structure, backend, internal, setup, tracing, trace, log, import, directory, field, blank, space, credential, file, size, limit, file , KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-PCM , iContent , Problem
Product
Attachments
| 404 Not Found.png |
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