SAP Knowledge Base Article - Public

2404204 - Unable to install Lumira Extension when using Citrix

Symptom

When using Lumira Desktop in a Citrix environment, Extensions will not install

Environment

  • Lumira Desktop 1.30
  • Lumira Desktop 1.31

Cause

This issue occurs because the extension installing process uses robocopy.exe to copy the extension files.  By default robocopy.exe can be found in the windows\system32 folder, but a citrix user may not have access to that folder.

Resolution

There are two ways to resolve this issue:

  1. Copy robocopy.exe to another location listed in the system PATH variable
  2. Manually copy the downloaded files from their temporary location (C:\Users\<username>\AppData\Local\Temp\sapvi\TempXsFileSystem_<somenumbers>) to the installed location (C:\Users\<username>\.sapvi\extensions\).  You will need to copy the bundles, eclipse, and features folders (They may not all exist for a particular extension)

Keywords

lumira extension citrix , KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem

Product

SAP Lumira, desktop edition 1.0