Symptom
The section headers do not appear in the form when a form template xml downloaded from Test instance is uploaded in Production
Environment
Performance Management
Reproducing the Issue
1. Login into test instance as admin> Admin tools>Performance Management> Form template settings
2. Click on the form template> Download the xml.
3.Login into Production instance as admin> Admin tools>Performance Management> Form Template settings>Upload the xml.
4.Launch a test form in production
5.Section headers are missing
6.Section headers did appaer in the from in Test instance.
Cause
There can be several reasons for this behavior, however, one of the reasons can be that the message keys defined in the xml of the form may not be defined in the Production instance.
Raise an case with Support so that they can check for the same.
Resolution
For Customer Success and Partners: Check for the message key defined for the section header in the xml of the form.
Then, download the message key file from the Production instance by Admin tools>Manage Form Label Translations
If the message key does not exist in the file, the section headers will not appaer.
You will need to reimport the message key file after addmin the required message key with the translation.
Keywords
KBA , LOD-SF-PM-FRM , Forms & Templates , Problem