Symptom
When trying to insert a new emergency contact:
- Insert the related fields and click on details;
- Under the details tab you select Copy Address from Employee to Yes but nothing happens;
Environment
SuccessFactors Employee Central
Reproducing the Issue
- Select any employee;
- Select Personal data;
- Navigate to Primary emergency contact portlet and click on edit;
- Fill the necessary information and click in details;
- Under datails change copy adress from employee to "yes";
- See that nothing happened;
Cause
There is an incorrect behavior regarding the adress fields under detail.
They should not appear unless the field " isDependent" is enabled and selected yes.
Furthermore there is also another wrong behavior than even if you enable this field, you have also to enable gender, dateOfBirth, ecNameAlt1 or ecNameAlt2.
There is an existing engineering ticket for this.
The correct behavior would be:
- If the customer has the field isDependent enabled, it should be possible to select whether to use the isAddSameAsEmployee but if the field isDependent is not enabled, the customer should not be able to even see the adress section under the details in primary emergency contact;
- Only the field isDependent is dependent should be relevant to whether enable the address section which is not happening
Resolution
- Navigate to manage business configuration;
- Under emergencyContactPrimary portlet check whether the field isDependent is enabled and case not, enable it;
- Also enable at least one of the fields below;
- gender;
- ecNameAlt1;
- ecNameAlt2;
- dateOfBirth;
This changes should solve the problem
Keywords
Copy adress from employee; Primary emergency contact error; Primary emergency contact is not copying the adress from employee; , KBA , LOD-SF-EC-PP3 , People Profile (PP3) , Problem