SAP Knowledge Base Article - Public

2406744 - Cannot create report by connection to SalesForce in Crystal Report for Enterprise

Symptom

  • Cannot connect to ODBC/JDBC connection in Crystal Report for Enterprise.
  • ODBC/JDBC connections are running in IDT.
  • Error: There was a problem accessing the Relational Connection on SAP BusinessObjects Business Intelligence platfom. Please check with your System Administrator that the connection is correctly configured. is observed in Crystal Reports for Enterprise client.
  • Error: Unable to retrieve the datasource configuration: java.lang.NullPointerException: while trying to invoke the method com.crystaldecisions.enterprise.ocaframework.IProxyHandler.invoke (java.lang.reflect.Method, java.lang.Object[], java.util.Map) of a null object loaded from field com.sap.connectivity.cs.remoting.corba.svchelpers._ConfigurationProxy.m_handler of an object loaded from local variable 'this'

2016-11-01_10-55-04.png

Environment

  • SAP BusinessObjects Business Intelligence platform (BI) 4.2 Service Pack (SP) 02
  • Windows Server 2012 R2

Reproducing the Issue

Open CMC. Disable all relevant Crystal Report servers.

Open Crystal Report for Enterprise. 

Create report based on Simba ODBC or JDBC connection. 

Cause

The relevant servers are not enabled. 

Resolution

Enable all relevant servers to Crystal Report.

Make sure Adaptive connectivity service and DSL bridge service are in APS server. 

See Also

 

1887880 - detail:Unable to find servers in CMS <CMSname>:<Port> and cluster @<clustername> with kind pjs and service null. All such servers might be down or disabled by the administrator. (FWM 01014)

 

 

 

Keywords

cr4e, cr, crystal report, 4.2, BI, BOBJ, server, datasource configuration, java.lang.NullPointerException, crystaldecisions, IProxyHandler, Relational Connection,  , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Server 2016