Symptom
You have created Extension Fields using Key User Tools (Adapt) and extended those to Form Templates. Then you used the process of Content Transfer to download and upload it in other tenant. The upload finished without errors and Extension Fields were also created, but you have noticed that those fields were not extended to form schema, so are not available in form template.
Environment
Cloud for Customer - C4C
Cause
The content transfer functionality will only transfer mappings (such as form template availability) to fields that were created in a target tenant as a result of a content transfer. If the fields already exist in the target tenant, the form template availability will not be transferred.
Due to some technical complexity this is not being supported. Form Templates are not considered in the export file, so in this forms case only Extension Field will be transferred, but not the RFBs.
Resolution
You will need to add it again in the target system manually by adding the extension field again to form template as required by Field Definition screen. So that the particular RFBs are getting addded and the extension field is added to form template as well.
Keywords
Content transfer, C4C, Import, Export, Layout , KBA , form template , import , export , layout , extension fields , content transfer , LOD-CRM-EMP , Employee , How To