Symptom
An user is able to modify Product Categories although doesn't have write permission to Product Categories.
Reproducing the Issue
1. Go to Products workcenter
2. Select Product Categories view
3. Find: Edit Product Categories: Standard Hierarchy
4. Click: Maintain Product Categories
5. User is able to tick/untick although he doesn't have write access
Steps to check the access restrictions
1. Go to Application and User Management workcenter
2. Select BUSINESS USERS view
3. Find the relevant business user
4. Click: Edit - Access Right - Acces Restrictions
5. Find: PMM_PRODUCTCATEGORIES
6. Write Access: No Access
Cause
The relevant Business User has access rights to Workcenter: Administrator--> View: General Settings.
This view requires read-write access to, among other things, Product Categories.
Resolution
Revoke the user access rights to Administrator->General Settings
1. Go to Application and User Management workcenter
2. Select BUSINESS USERS view
3. Find the relevant Business User
4. Click: Edit - Access Right - Work Center View
5. Find: SEOD_ADMIN_SETUP_WCVIEW
6. Uncheck the box Assigned User
Keywords
KBA , AP-PRO , Project Processing , How To