SAP Knowledge Base Article - Public

2409336 - PP3 - Payment Information UI not working the same in Add New Employee

Symptom

When in the Add New Employee wizard, the Payment information UI is not working the same as on the users People Profile.
For example any of the following may be happening:

  • UI Rules are not working the same
  • Field layout is different.
  • Different field are shown.
  • Fields are missing.

Environment

  • Employee Central - PP3 - People Profile 3

Reproducing the Issue

  1. Navigate to the Add New Employee Wizard.
  2. Add Payment Information
  3. The Payment Information UI is not the same as on the users People Profile.

Cause

  • The UI which is used in the Add New Employee Wizard is the UI defined in 'Personal Information Screen Lookup' in Manage Data. The UI which is used in People Profile is the UI defined in Configure People Profile.
  • This issue is caused because the UI defined in 'Personal Information Screen Lookup' in Manage Data is different than the one defined in Configure People Profile.

Resolution

  • To provide consistence across the instance, we recommend using the same UI in both places.
  1. Go to Admin Centre-> Manage Data.
  2. In the Create New dropdown menu, select Personal Information Screen Lookup.
  3. Enter the relevant information.
    • Object Type: Select Payment Information in the dropdown menu.
    • screenID: Select a configuration UI.
  4. Click Save.

Keywords

Payment Information, Add New Employee, Hire Wizard, Field order, Manage Configuration UI, PP3   , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem

Product

SAP SuccessFactors Employee Central all versions