SAP Knowledge Base Article - Public

2409723 - Add New Fields in the Responsive UI

Symptom

You need to add new fields in your report. The fields after a certain alphabet character do not appear anymore in the drop-down list. It means that you cannot see all fields available in your system.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Analysis work center and the Reports view.
  2. Find and open XYZ report.
  3. Go to the Add Fields feature.
  4. You will see that the fields after a certain alphabet character do not appear anymore in the drop-down list, e.g., you want to add Opportunity field and the drop-down list shows only fields up to alphabet "M".

Cause

This behaviour is caused by the system display functionality, where only a limited number of fields from those selected can be displayed in the screen.

Resolution

In order to add a specific field, you'll need to remove unused fields from the selection.

1. Go to the Business Analytics work center and the Design Reports view.
2. Show All and Find report XYZ.
3. Open the report.
4. Go to the Add Fields button.
5. Go to the Characteristics tab.
6. Uncheck the fields which are not necessary.
7. Check the fields which you want to see in your report.

Keywords

Report, Analysis, Field, Field, Help Value, add field, add fields , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions