Symptom
After creating an account or contact where you included values for fields such as Address Line 1, District or a middle name, the same fields are not displayed in display mode of the object.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: Address Line 1/ District for the Account view, or Middle Name for the Contact view are marked as visible via adaptation mode.
- Go to the Customers work center.
- Go to the Accounts or Contacts view.
- Open any account or contact.
- Maintain for example Address Line 1/ District for an account, or Middle Name for a contact.
- Save.
The field Address Line 1/District or Middle Name is not displayed in the header.
Only when you click into the field while in Edit mode do the fields become available.
Cause
In the Account (also in the other Business Partner UI's) we have several name and address fields which are only available in edit mode and other fields which are only available in read-only mode. The reason for this is that we did not want to overload the object Header. Therefore the single name/address fields (e.g. "Address Line 1") are available in an edit mode only.
Resolution
This is the system standard behavior. You can change the field behavior by following the steps below:
- Login in the system.
- Go to the Customer work center.
- Open the Account view.
- Open account ABC (where ABC stands as the account ID).
- Click in Adapt button.
- Select Edit Master Layout option.
- Click in Edit button.
- Hover the mouse over the now visible field Address Line 1/District.
- Select Change Properties.
- In the Change Properties pop-up, select 'Visible in Read and Edit mode' option in the drop-down menu.
Keywords
Adaptation Mode, District Field Missing, Middle Name, Address Line 1 Missing, Field Visible Flag , KBA , middle name , LOD-CRM-ACC , Account , How To
Product
Attachments
A.PNG |