SAP Knowledge Base Article - Public

2412449 - getTotalPhysicalMB windpapi API crash in Lumira Desktop

Symptom

SAP Lumira Desktop shows an error message and crashes during startup for non-admin users; it only works with an administrator account. The following error message pops up:

An error has occurred. See the log file <PATH_TO_LOG_FILE>

The log file generated during crash contains the following error messages:

!MESSAGE Could not bind a reference of component com.sap.ip.bi.base.application.DeclaredServiceActivator.

!MESSAGE Application error

!STACK 1

java.lang.UnsatisfiedLinkError: com.sap.hilo.security.encryption.internal.windpapi.JniFacade.getTotalPhysicalMemoryInMB()J

In the Event Viewer, the following entries can be found:

Warning: AppSense Application Manager denied execution of <USER WORKING DIRECTORY>\appdata\roaming\.sapvi\configuration\org.eclipse.osgi\bundles\626\1\.cp\native\hilo_windpapi.dll

Environment

 The application is delivered via Citrix Xenapp, however the privilage-related root cause can be reproduced in other environments running AppSense Application Manager.

  • SAP Lumira Desktop
  • Citrix Xenapp 6.5
  • AppSense Application Manager
  • Microsoft Windows Server 2008 R2 hosting Citrix

Reproducing the Issue

  1. Start Lumira Desktop client with an affected user
  2. An error message informing about the crash appears, and points to a log file (contents outlined in symptom section)

Cause

  • The AppSense Application Manager is blocking user's access to directories required to run Lumira Desktop client

Resolution

Configure the AppSense Application Manager to grant SAP Lumira access to the following resources:

  • Installation directory; i.e. %ProgramFiles%\SAP Lumira\
  • User instance and configuration directory; i.e. %HOMEPATH%\.sapvi\
  • Local public directory (in case of product activation issues); i.e. %PUBLIC%\sapvi\

 

Keywords

KBA , BI-LUM-DIS , Lumira Desktop/Discovery , Problem

Product

SAP Lumira, desktop edition 1.0