SAP Knowledge Base Article - Public

2413999 - Survey Link Not Working in Campaign E-mails

Symptom

When you execute an E-mail Campaign with a Survey link, the E-mail received will have the Survey link as inactive.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Go to the Sales Campaign Work center.
  2. Go to the Campaigns view.
  3. Open the campaign ABC.
  4. In the Build tab, Email with Survey link has been added.
  5. Choose Actions and then Send Test e-mail.
  6. You are able to open the survey link from the received e-mail.
  7. Now, execute the campaign.
  8. The recipients from the target group have received the email but the survey link is inactive.

 

Cause

The link to external Surveys used in the email templates for campaigns works only for the members of the type: Person. Because it is expected that when a link to an external survey is sent in an email, it will be clicked by a Person. In this case, if we send an email to the contact or the individual customer, it would work fine. But if the email is sent to an account, the link doesn't work.

Resolution

  1. Go to the Marketing workcenter.
  2. Go to the Campaigns view.
  3. Open the campaign ABC.
  4. In the Overview tab, choose the Target group.
  5. Navigate to the Members tab.

Here, ensure that the members are not accounts.

 

Keywords

E-mail Campaign, Survey Link , KBA , LOD-CRM-MKT-CAM , Campaigns , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions