Symptom
Application error is received when submitting a leave payout request
Environment
- SAP SuccessFactors Employee Central
- v12 / People Profile (PP3)
Reproducing the Issue
1. Proxy as an admin user then navigate to Time Off section of the employee where the payout is to be requested.
2. Click on Administer Time link then go to Time Accounts tab and select a time account.
3. Under Account Postings section, click on Add Payout.
4. Set a posting date, account payout, then enter number of payout. Click Save.
Cause
Email notification template for the Time Account Payout Actual Values Notification is missing.
NOTE: Product Support - please see Internal Note for log example
Resolution
If the subject and body has already been maintained and error persists, apply some template changes temporarily (i.e. changing the email body text) then save the template again by clicking on Save Changes button. If the subject and body is missing, maintain the Time Account Payout Actual Values Notification template accordingly in Admin Center > Email Notification Templates.
Default email template is provided below.
Email Subject
Time account payout notification for [[RECIPIENT_NAME]].
Email Body
Hello [[RECIPIENT_NAME]],
[[SUBJECT_USER]] has requested an account payout on your behalf.
Account: [[TIME_ACCOUNT]]
Payout amount: [[PAYOUT_AMOUNT]]
Payout unit: [[PAYOUT_UNIT_OF_MEASURE]]
Posting date: [[EFFECTIVE_DATE]]
The payout will appear on your next payroll slip.
Regards,
SuccessFactors
NOTE: DO NOT change/modify the standard tags [[ ]] of the template as this would cause issues with the email notifications for the leave payout actions
See Also
2396068 - Time Payout Issue
Keywords
Time Account payout, email notification, application error, account payout, Manage Time Off, Time Off, leave payout, ECT-65001 , KBA , nullpointerexception , timeoffemailnotification , ad14fa17c8032897fe41add994c834b7ce2fa0b6 , emailmessage , LOD-SF-EC-TIM , Time Off , LOD-SF-EC , Employee Central , Problem