Symptom
- Need to open the New Hire activities page but it fails.
- Cannot open the New Hire activities page for a newly added candidate.
- When trying to access the New Hire activities page for a newly added candidate an error message is displayed, preventing the manager from moving forward.
Environment
SAP SuccessFactors Onboarding
Cause
This can occur because of:
- The last name or first name are missing in BizX
- The candidate record was deleted in BizX but is still available in ONB
- Candidate name changed in BizX
Resolution
To resolve this, follow steps below:
- In Admin Center => Import and Export Data, export all data records for object: OnboardingProcess
- In Admin Center => Monitor Job, download the file for all objects.
- In the downloaded ZIP file, you'll find files for both OnboardingCandidateInfo object and OnboardingProcess
- Open OnboardingCandidateInfo object and Identify a hire assigned to the impacted user
- Back in the ZIP file, now open up the OnboardingProcess file and see the onboarding Process ID
- In Admin Center > Manage Data, Onboarding process => enter Onboarding Process ID.
- Set this Process to "Complete", it allows a user to access the Hiring Manager Activities
Note: The Last Name should always be a required element within BizX to ensure this populates from ONB if the userID was already deleted from Bizx. If the corresponding onboarding process was not deleted from the system, it will still look for the candidate record in BizX and will fail, throwing an error message.
See Also
Support Engineer please see internal memo
Keywords
SF Success Factors, New Hire Activity Error, not accessible, time stamp, ONB, OBD, SFDWRExceptionConverter, compareToIgnoreCase, NewHireInformationResultBean.getUserLastName , KBA , LOD-SF-OBD , Onboarding , Problem