Symptom
- When a User who previously left a position and has a Terminated Date populated is merged with a new user account after being re-hired, the Terminated Date is populated into the Merged Active Uesr Account
- This causes the User to be locked out and unable to login, even though he/she is an active user
Environment
- SAP SuccessFactors
- Learning Management System (LMS)
Reproducing the Issue
Create 2 User accounts that are the same/similar, except:
- User1 has been terminated
- Set Terminated Date to date in the past
- Set to Active to No
- User2 is not terminated
- Terminated Date is blank
- Active is Yes
- Navigate to User > Tools > Merge Users
- Use search criteria that returns both User1 & User2
- Select User1 as "Merge From User ID"
- Select User2 as "Merge Into User ID"
- Merge the Users
- Note that User1 is inactive (as expected)
- User2 remains active, but has a Terminated Date populated
- User2 is now unable to login to the LMS
Cause
- Product Management has confirmed this is expected behavior (LRN-16221)
- Merge User functionality is meant to be used for 2 existing active accounts
- If a User is being rehired, the existing account should be used, following a re-hire scenario
Resolution
- If Termination date isn't needed for an active user, remove the termination date from UserSnapshot prior to merging
- - Or -
- Use Rehire instead of merging a terminated user with an active user
Keywords
SF SuccessFactors Success Factors Learning Management System LMS terminate date merge user populate add lock block unable cannot login account active rehire , KBA , LOD-SF-LMS , Learning Management System , Problem
Product
SAP SuccessFactors Learning all versions