Symptom
Example 1:
Changes done in Activities tab (Customer>Account>Activities tab) are not visible after saving.
Example 2:
You have no option to rearrange sections in the Activity tab in Edit Master Layout.
Reproducing the Issue
- Log into system.
- Navigate to Customers and the Accounts.
- Open any Account and go to Activities.
- Click on Adapt and then Edit Master Layout.
- Try to rearange the order of the Activities sections or do advanced edits.
Cause
Enhanced activities facet (/BYD_COD/SalesOnDemand/Activities/COD_ACTIVITIES_EC.EC.uicomponent) hasen't been scoped.
Resolution
- Log into C4C.
- Go to Business Configuration WoC.
- Select Implementation Projetcs.
- Select Edit Project Scope.
- Go to Section 4 - Questions.
- Select Scoping Element Sales, then Account and Activity Management and then Activity Management.
- Flag the checkbox for the activities option Do You Want to Enable and Enhanced Activities Facet to Search and Query for Activities in Account, Contact and Individual Customer Workcenters.
- Click on Next.
- In Review Status pop-up select YES.
- Click Finish.
Now the enhanced Activities tab should be active in your system.
See Also
Hybris Cloud for Customer has two Activities tabs that can be selected by scoping in Accounts, Contacts and Individual Customer workcenters.
If not scoped, the basic tab will be available with default set features (/BYD_COD/SalesOnDemand/Account/UI/COD_Account_TI.TI.uicomponent).
The advanced tab has to be scoped in order to be available (/BYD_COD/SalesOnDemand/Activities/COD_ACTIVITIES_EC.EC.uicomponent).
For the EC tab type it is not possible to apply changes for individual users due to a limitation, but the TI tab type can be used to develop changes.
Keywords
KBA , LOD-CRM-EMP , Employee , How To