SAP Knowledge Base Article - Public

2417754 - Opportunity (or Ticket) Cannot Be Submitted For Approval

Symptom

Action Submit for Approval is greyed out.

Environment

  • SAP Cloud for Customer

Reproducing the Issue

Prerequisite: You have set up an approval process and maintained all of the steps necessary to allow an document to be submitted for approval.

We will use Opportunity as an example but the same applies to Tickets:

  1. Go to the Sales work center.
  2. Select the Opportunities view.
  3. Open an Opportunity XYZ (XYZ represents Opportunity ID).
  4. Click on Actions.
  5. Submit for Approval is greyed out despite the relevant approval conditions are being met.

Cause

The Opportunity/Ticket was created before the approval processes were set up.

Resolution

This is expected system behavior. Only documents that were created after the approval processes were set up can be submitted for approval.

Keywords

Approval, Opportunity, Ticket , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1611 ; SAP Cloud for Customer core applications 1702 ; SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1805