SAP Knowledge Base Article - Public

2419041 - Unable to navigate to LMS and gets java.lang.NullPointerException error

Symptom

When logging to LMS or navigating from SF platform to Learning, the user gets the following error message:

"java.lang.NullPointerException: while trying to invoke the method com.plateausystems.elms.bo.i18n.valueobject.I18nTimeZoneVO.getLabelID() of a null object loaded from local variable 'vo'"

Reproducing the Issue

  1. Log in to https://customerinstance.plateau.com/learning/user/nativelogin.jsp
  2. Launch Proxy for a user

Cause

Time Zone was not set up for the user

Resolution

  1. Log in as an admin;
  2. Go to Users > search for the User ID and click Search;
  3. On the User Profile, click More next to Related;
  4. Click Preferences;
  5. Enter user's preferred Time Zone;
  6. Click Apply Changes.

Keywords

java.lang.NullPointerException, error, login, lms, user , KBA , LOD-SF-LMS , Learning Management System , Problem

Product

SAP SuccessFactors Learning all versions