SAP Knowledge Base Article - Public

2419072 - Fields coming from Employee Central are empty/blank on the forms - Compensation

Symptom

When launching a form there may be columns which are not displaying any data (as shown below):

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"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Compensation Management

Reproducing the Issue

  1. Go to Compensation
  2. Open Compsensation Form
  3. Check fields with blank data (assuming columns contains data via Adhoc Reports).

Cause

  • This can be related to a configuration error where an incorrect field from EC has been configured as source
  • In some other cases it is related to changes in the Business Configuration where the visibility of a field has been removed.
  • Lastly this can be caused by rules which are defined on certain EC fields but do not save. For example, populating data from field1 to field2 but this does not save. This therefore can cause blank data.

Resolution

Pease check the following:

1. Ensure the impacted field is configured as Enabled = Yes in Admin Center> Manage Business Configuration.

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2. If this has been checked please go into the problem users profile and resave their data under the portlet you are trying to pull data from.

3. You may also leverage using ADHOC reporting to establish if data in EC is populated so it may flow correctly into Compensation.

4. This can be done by create a report on the Job Information (Date Range) domain.

Keywords

empty field, map from ec, hris empty field, blank columns, compensation ec, ec fields blank, missing ec data, mapped ec data, missing ec data , KBA , LOD-SF-CMP , Compensation Management , LOD-SF-CMP-EC , EC data, EC mappings, configuration & settings , Problem

Product

SAP SuccessFactors Compensation all versions ; SAP SuccessFactors HCM Suite all versions