Symptom
- Unable to view Employee Profile Domain's Ad Hoc Report when user proxies as another user
- User is unable to see Employee Profile Domain Ad hoc report on Proxy
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- Ad Hoc Report Builder (Employee Profile Sub Domain Schema Only)
Reproducing the Issue
- UserA, UserB, UserC have permission to create and run ad hoc reports of all domains.
- UserA has created an ad hoc report called "Test" of Employee Profile Domain.
- UserA has shared the "Test" report with UserB, UserC.
- Now, UserB and UserC are able to view the shared "Test" report while they login using their credentials in SFSF instance.
- If UserA login and proxies in as UserC then UserA is able to view "Test" report under UserC's account.
- If UserB login and proxies in as UserC then UserB is NOT able to view "Test" report under UserC's account.
- If UserB login and proxy in as UserC then UserB is able to view all other ad hoc reports (not created based on EP domain) under UserC's account.
Cause
- UserB does not have Proxy permission for Employee Scorecard.
Resolution
Go To Admin Center > Proxy Management > Please ensure that "Employee Scorecard" proxy permission is checked
Keywords
Ad, Hoc, Report, Table, Center, Proxy, Employee, Profile, Scorecard, Unable, missing, doing, Domain, sub, schema, module , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem
Product
SAP SuccessFactors HCM Suite all versions