Symptom
- Need to update business address for Section 2 of the Form US I-9 in Onboarding
- Onboarding activity is completed, is there anyway to correct the information in the US I9?
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding 1.0 - All Versions
Cause
Incorrect data entered in US Form I-9 fields in Onboarding panels
Resolution
For Live Customer(s)
The current build of the system does not support re-routing activity back to New Employee Step or Orientation Step to edit fields with incorrect data. As a work-around we have 2 working solution for this kind of scenario.
Manual US Form I-9 Update
This is only applicable for customers without E-Verify integration.
- Step 1: Download the original signed US Form I-9 in Document Center
- Step 2: Manually update the fields with incorrect value
- Step 3: Scan the form
- Step 4: Upload and attach a memo stating why it needs to be corrected in Document Center
Note
For audit purpose, keep the old US Form I-9 in Document Center
E-Verify Correct Data
If E-Verify process is enabled, please follow the correct way to edit US Form I-9 using the system's workflow, see KBA 2244508
Keywords
SAP SuccessFactors, Onboarding, Compliance, US Form I-9, Complete, Finish, Correct Section, Edit Fields, Process, Candidate, Activity, Correct Data, E-Verify, BasicPilot , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , How To