SAP Knowledge Base Article - Public

2419447 - Unable to Purge users using Inactive Date Period (Purge Rule)

Symptom

  • I have set up a purge rule whereby I want to purge users who are inactive for a certain period. The rule does not trigger any inactive users to be purged when selecting inactive date period.
  • It purges inactive users if Inactive period is set to "N/A"

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

  • BizX Platform
  • This does not apply to Employee Central Instances

Reproducing the Issue

  1. Navigate to Admin Center > Data Management 
  2. Create New Purge Rule > Purge Inactive User
  3. Select Multiple Users and set the Inactive Date period to your request(eg 90 Days) 
  4. Exclude user depending on the type of request
  5. Select Approver 
  6. Launch

Cause

  • The purge rule for inactive date period fails because the company exit date is not configured in the Data Model. 
  • For the DRM user select logic, it will use the company exit date to calculate the inactive time.
  • This needs to be manually selected in Manage Users, If it is not visible in Manage Users then this needs to be configured.

Resolution

  • Check manage users to see if "Company Exit Date" is selectable. If it is not it needs to be configured in the Data Model.
  • The following needs to be added to the Data Model
  • <standard-element id="companyExitDate" max-length="100" required="false" matrix-filter="false">   
    <label xml:lang="en-US">Company Exit Date</label>
    </standard-element>
    KBA_companyExitDate.png

 

  • You will also need to configure companyExitDate in "sysUserDirectorySetting" and "sysVisableUserDirectorySetting"
  • Here configuration of "companyExitDate" is similar as other elements configuration like username, firstname, lastname, hiredate etc.
  • Simply duplicate one standard element configuration in  "sysUserDirectorySetting" and in "sysVisableUserDirectorySetting", delete the standard element ID and insert companyExitDate 
    kba_sysVisibleUserDirectorySetting.png

 

 

kba_sysUserDirectorySetting.png

View:

  • 2617614 - Employee Profile: How to Configure companyExitDate Field under Manage Business Configuration

Code :

EP or Employee Profile standard:

<standard-element id="companyExitDate" max-length="100" required="false" matrix-filter="false">

<label>Company Exit Date</label>

<label xml:lang="en-US">Company Exit Date</label>

</standard-element>

UDF file or Basic import file:

<view-template id="sysUserDirectorySetting" jsp-file="" visibility="none" pdf-printing-enabled="false">

    <label>User Directory Setting</label>

    <label xml:lang="en-US">User Directory Setting</label>

    <description>User Directory Setting</description>

    <description xml:lang="en-US">User Directory Setting</description>

    <edit-template id="sysAllUserDirectorySetting">

<standard-element-ref refid="companyExitDate"/>

</edit-template>

    <edit-template id="sysVisibleUserDirectorySetting">

      <label>User Directory Setting(Visible)</label>

      <label xml:lang="en-US">User Directory Setting(Visible)</label>

<standard-element-ref refid="companyExitDate"/>

 </edit-template>

EC  Hris sync from: EC to EP Mapping

<hris-element-ref refid="employmentInfo">

      <hris-mapping>

       <hris-field-ref refid="end-date"/>

       <standard-element-ref refid="companyExitDate"/>

      </hris-mapping>

  • Upload the newly configured data model to the customers instance via Provisioning
  • You should now see "Company Exit Date" in the customers instance
  • Manually select the date and create the rule again. 
  • This should now find users based on your query and inactive date period. 

NOTE: If a user is an EC user the "inactive time" respected is maintained under the Data Inspector "Table_EMP_EMPLOYMENT_INFO" > "END_DATE". If the user not an EC user the "inactive time" will follow table in the Data Inspector "Table_USERS_SYSINFO" > "USER_SYS_EXITDATE"

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Guide: Implementing and Managing Data Protection and Privacy

Chapter: Termination Date Between Employee Central and Standard User Fields

Q) Is it possible to re-activate purged users which have been soft purged using the legacy purge inactive user Data Retention Management Purge or Data Retention Time Management Purge?

A)  Yes, A Soft purge is when the user is still existing at the Database level. View : 2392094 - Re-activate a Purged User Via employee Import Feature

See Also

  • 2617614 - Employee Profile: How to Configure companyExitDate Field under Manage Business Configuration
  • 2643327 - Missing 'Company Exit Date' Field in User Profile for DRTM
  • 2614665 - Syncing the Termination Date between Employee Central and the SuccessFactors Platform
  • 2584658 - HRIS Sync - How to Check if a User is an EC User using the Integration Center 
  • 2545988 - How to Purge/Delete users in SuccessFactors 
  • 3058601 - How To Check Soft or Permanent Purge User
  • 2080728 - Employee Central: What is HRIS Sync?

Keywords

Data Retention Management, Purge, Purge Rule, Inactive Users, Date Period,companyExitDate, companyExit Date, terminate, end date , KBA , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-EC-TER , Termination Details , LOD-SF-EC-DRM , Data Retention Management - (DRM & DRTM) EC Data Only , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-PLT-DRM , Data Retention Management , Problem

Product

SAP SuccessFactors HCM Core all versions