Symptom
When using ABBYY - Business Card Scanner app, the following error appears:
The operation couldn't be completed.
Encountered an error: Unauthorized.
The operation couldn’t be completed. (NSURLErrorDomain error – 1012)
Environment
SAP Cloud for Customer
Reproducing the Issue
[Enter your Reproducing the Issue here...]
Cause
The message means either your account does not have a valid license, run out of quota or it's wrong configured.
Resolution
These are the possible solutions for this problem:
- You must hve a valid license from the vendor of this service to use it. Access this ABBYY site to obtain a license. If you already have a license, login to ABBYY site and check if you have enough quota.
- After obtain a license or confirm it's valid, you need to update the Mashup WebService inside Cloud for Customer Admin:
- Go to Administrator WoC.
- Go to Mash-up Web services View.
- You will find a pre-delivered web service called “Business Card Scanner Service. Click to Enter APi Key.
- Now you should configure the available fields: "basic_username" must contain the Application ID information and "basic_password" must contain the given password.
Keywords
ABBYY, Card Scanner , KBA , abbyy , business card scanner , AP-RC-GEN-MSH , Mashups , How To
Product
SAP Cloud for Customer add-ins all versions