SAP Knowledge Base Article - Public

2420829 - Error Message: "Service Call Failed; Report an Incident", While Migrating Projects

Symptom

When you migrate Projects, system throws below error message:

Service call failed; report an case.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Business Configuration work center.
  2. Go to Implementation Projects view or Overview view. 
  3. Search and Open the activity Migration of Projects.
  4. Choose Migrate projects using the migration tool.
  5. Execute Migration for the respective Migration File.
  6. You receive an error message during the Simulation step:

Service call failed; report an incident.

Cause

The system is facing a very high memory consumption while migrating the Project from a template due to high number of Information Messages that is raised.

Resolution

To avoid the error, please change the following in the given Project data, so that the migration can work even for a big Project.

1) Change the Project Task descriptions to text with a maximum length of 40 characters. This will avoid the Information Message which informs about the truncation of the text.

2) Please check the Duration given in the Task details. It does not match with the given date so that the Duration will be adopted during migration. This causes also, always an Information Message as the Duration will be adopted according to the given dates. Leave the Duration empty for each Project Task and let the system calculate it automatically.

3) In the tab Task Details, check how many project tasks are being maintained. Please try to not maintain more than 200 records. More than this and they system may not work reliably.

We are working on improvements to avoid this high memory consumption during Migration.

Keywords

Project; Migration Tool; Service Call; Duration; Task; Memory , KBA , migration of projects , project task descriptions , duration , AP-PRO , Project Processing , How To

Product

SAP Business ByDesign all versions