Symptom
Customer requires the "Status" view permission to be enabled in Role Based Permissions under "Employee Data" section, but the permission is not present when viewing RBP.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors HCM Suite
- BizX Platform
- Role Based Permissions
Reproducing the Issue
Customer tries to enable the "Status" view permission in Role Based Permissions under "Employee Data" section, but the permission is not present when viewing an RBP role.
Cause
- The "Status" view permission is not enabled or visible in Role Based Permissions under "Employee Data" section.
- It is necessary to configure this first in the Data Model before this will display in the front end of the instance in "Employee Data" section in Role Based Permissions.
Resolution
- Check if the "Status" Permission is present in the Section "Employee Data" in Role Based Permissions
- If the status field is not present, Navigate to the customers Provisioning and download the Data Model. Make a copy of the Original Data Model downloaded for a backup.
- In the Data Model, among the standard-elements configured at the top of the Data Model, add in the following code.
<standard-element id="status" max-length="2" required="false" matrix-filter="false">
<label>Status</label>
</standard-element>
- Save a new copy of the Altered Data Model
- Upload this new Data Model in Provisioning where you downloaded it from
- Check in the instance, the "Status" permission should now be visible in the Front End of the instance, as below:
- Status permission should now be visible in Role Based Permissions
See Also
See 2419522 - SF Mobile Search not working
Keywords
Status View Permission Data Model search employees mobile application Role Based Permissions Employee Data enable edit add configure , KBA , LOD-SF-PLT , Platform Foundational Capabilities , LOD-SF-PLT-RBP , Role Based Permissions , How To