Symptom
- Fields name appear like: Expr1000, Expr1001, ...
- When connecting to an Amazon Redshift data source from Crystal Reports via an ODBC connection, the database fields name display like: Expr1000, Expr1001,...
- When refreshing a report based off an Amazon Redshift data source in Crystal Reports, it fails with the error:
"Failed to retrieve data from the database."
"Details: HY000:[Amazon][RedShift ODBC] (30) Error occurred while trying to execute a query: ERROR: column <Table Name>.expr1000 does not exist. [Database Vendor Code: 30]"
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- Amazon Redshift
Reproducing the Issue
- Configure an ODBC Connection to the Amazon Redshift data source.
- In Crystal Reports, create a new report off Amazon Redshift using an ODBC connection.
- In the "Field Explorer", notice the database fields for the select table display as: Expr 1000, Expr 1001,… Instead of the actual expected field name, like: Country, Customer Name, ….
- Add at least one database fields to the Details section of the report.
- When refreshing the report, it fails with the following error:
"Failed to retrieve data from the database."
"Details: HY000:[Amazon][RedShift ODBC] (30) Error occurred while trying to execute a query: ERROR: column <Table Name>.expr1000 does not exist. [Database Vendor Code: 30]"
Cause
- This issue has been traked under SAP Note 2291014
Resolution
- The issue has been resolved in the following product update and above:
- Crystal Reports 2013
- Support Pack 05 - Patch 14
- Support Pack 06 - Patch 8
- Support Pack 07 - Patch 3
- Support Pack 08
- Crystal Reports 2016
- Support Pack 02 - Patch 1
- Support Pack 03
Keywords
CR, redshift , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016