SAP Knowledge Base Article - Public

2423627 - Web Service ManagedTicket - ID Mapping

Symptom

You are using web service ManageTicket to send tickets from ERP to C4C via web service and you expect to use the same ERP IDs in C4C.

However, C4C does not use ID mapping, but uses C4C internal IDs.

(For customer ID, the equipment ID, functional location ID, material ID etc.)

Environment

SAP Cloud for Customer 1711

Cause

The A2X service of Ticket does not provide the capability to convert the external ID to internal ID (ID mapping).

Resolution

You have to setup the integration between the C4C system and ERP system and maintain the external ID within the C4C internal objects to read those internal IDs and use it for ticket creation.

Keywords

ManagedTicket, web service, external ID, internal ID , KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer core applications all versions ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711