You are unable to search for an Account using the Employee field in the Advanced Search.
Symptom
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to the Customers work center.
- Navigate to the Accounts view.
- Select All to display all Accounts.
- Click on the Advanced Search icon.
- Open the value help for the Employee field.
The system does not display any Employees in the value help, and no input field is provided to select an Employee.
Cause
- You are logged on with user ABC (ABC represents the User ID), who is assigned to Business Role XYZ (XYZ represents the Business Role ID).
- The Business Role XYZ does not have access to the relevant Employees work center view.
- As a result, users assigned to Business Role XYZ are unable to view Employees in the value help of any work center view.
Resolution
Grant Read Access to the Employees work center view for the relevant Business Role to allow users to view Employee information without modifying any data.
Follow the steps below:
1. Go to the Administrator work center.
2. Navigate to Users → Business Users.
3. Search for and open user ABC (ABC represents the User ID).
4. Click Edit and select Access Rights.
5. Under Business Role Assignment, select role XYZ (XYZ represents the Business Role ID).
6. Click View All.
7. Navigate to Access Restrictions.
8. For the People work center and the Employee work center view, set Read Access to Unrestricted.
After saving the changes and logging off/on again, the user will be able to view Employees in the value help.
Keywords
Account, Employee, Advance Search, Customers, Business Role, Access Restrictions , KBA , LOD-CRM , Cloud for Customer , How To
SAP Knowledge Base Article - Public