Symptom
You are unable to search for an Account using Employee field in advanced search.
Reproducing the Issue
- Go to Customers work center.
- Go to Accounts view.
- Select All to search for all Accounts.
- Click on Advanced Search icon.
- Select value help for Employee field.
Employees are not visible and system doesn't provide any input field to select the Employee.
Cause
You are logged in with user ABC(where ABC is the user ID) who is assigned Business Role XYZ(where XYZ is Business Role ID).
The Business Role XYZ is not given access to the Employees work center view.
Hence the users from the Business Role XYZ will not be able to view the Employees in the value help of any workcenter views.
Resolution
You can give read access to the Employees view to the Users whom you wish can access Employee information but not make any changes to their data.
- Go to Administrator work center.
- Go to Users view and select Business Users.
- Search for user ABC and open it.
- Click on Edit and select Access Rights.
- Under Business Role Assignment select XYZ.
- Click on View All.
- Navigate to Access Restrictions.
- For People work center and Employee work center view mark Read Access as Unrestricted.
Keywords
KBA , LOD-CRM , Cloud for Customer , How To