Symptom
- When looking for an Employee and scrolling down to Job information we get script error and the job information of the Employee does not appear.
- When in new hire page, traversing to job information section results in application error with fingerprint: 63f4ee8bffac238732c162d4ef9f812305109796.
Environment
Employee Central - Employment Information
Reproducing the Issue
- When looking for an Employee and scrolling down to Job information the error is received.
- Navigate to Job Information section after earlier sections loading without issue, receive an application error
Cause
- External Codes were missing for OBSOLETED ISOCountry picklist
- External Codes missing for ACTIVE ISOCountry picklist
Resolution
There were OBSOLETED or ACTIVE ISOCountry in picklist which do not have an external code.
- Assign external code to the blank OBSOLETED or ACTIVE 'ISO country picklists' and upload.
OR
- Mark OBSOLETED ISO country picklist as DELETED and upload.
Explanation:
We see from the error logs that the issue is while trying to pull country values from ISOCountry picklist.
Just to be sure, we disabled permission from 'Country' for the Admin Role and then the Admin Role was able to see all job info of all employees. If we enable the permission to view country then the error occurs again.
Admin Center -> Manage Permission Roles -> Permission -> Employee Central Effective Dated Entities -> Country
While displaying, it is trying to pull country but getting null error.
Keywords
63f4ee8bffac238732c162d4ef9f812305109796, error, job information, ECT-66208, ECT-29335 , KBA , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem