SAP Knowledge Base Article - Public

2424027 - Employee not able to apply leave for a past date

Symptom

Employee not able  to apply leave for a past date

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

Successfactors - Employee Central: Time Off

Reproducing the Issue

1. Employee is trying to apply leave for a past date (Say 25th Nov 2016)

2. On checking the balance as of 25th Nov 2016, the employee is having good number of hours to apply leave.

20.jpg

3. But on requesting leave, the error message occurs 'You cannot take 8:00 hours because you have no balance left'

21.jpg

Cause

1. There are leaves applied in the future(i.e after 25th Nov 2016) due to which there is no balance in the Time Account.

2. There are manual adjustments done in the future(i.e after 25th Nov 2016) to negate the balance in the Time Account.

22.jpg

Resolution

  • If leaves are applied or manual adjustments are done in the future. This will deduct the balance from the Time Account.
  • Therefore even though the Time Account shows balance is available as of a given date, there may not be any balance left in the Time account due to the above reason.
  • To resolve this issue the user will need to adjust the future leaves or manual adjustments to allow for enough balance to request a leave on a past date.

Keywords

You cannot take 8:00 hours because you have no balance left, No balance left, Time off, Leave, past date, not able to apply leave , KBA , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions