SAP Knowledge Base Article - Public

2424377 - Outbound Payment File is Not Consistent

Symptom

You have observed that the Outbound File created is empty.

Logs shows that File Format e.g. APAY Z_HSBC is not consistent.

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Go to Liquidity Management work center.
  2. Go to File Management view.
  3. Go to Outbound Files subview.
  4. Show All Files and Find Outgoing File ID XYZ (XYZ represents the outgoing file ID).
  5. Choose the File and Go to Attachment.
  6. Choose Display Log.

Error message shows as File is not consistent.

Cause

One possible cause for this issue is that you have given Field Length for the field ADVICE-TEXT as 2 and ideally it should be 999.
It is also recommended that you maintain:

  1. Field Length for Field Intermediary Bank Name should be 35.
  2. Character Set Assignment as UTF-8.

Resolution

Field Length for field ADVICE-TEXT can be changed by following steps:

  1. Go to Business Configuration Work center.
  2. Go to Implementation Projects.
  3. Select the Project and Choose Open Activity List.
  4. Show All Activities and Find Activity Outgoing Bank Transfers.
  5. Choose view.
  6. Go to Edit Payment File Structures.
  7. Go to File Structure ID Z_HSBC and Choose Edit.
  8. Go to Define Fields.
  9. Select the Field ADVICE-TEXT.
  10. Go to Tab Field Content Definition and go to Data Positioning and change the Field Length to 999.

You can also check the Character Set Assignment by following steps:

  1.  Follow Steps 1 to 5.
  2. Go to Edit Assignment of Payment File structures to the Payment Medium Formats.

You can check the Character Set assigned to File Structure ID and it should be UTF-8 for File Format APAY Z_HSBC.

See Also

Keywords

 Outbound, Payment File, Not Consistent. , KBA , SRD-FIN-CLM , Cash and Liquity Managment , How To

Product

SAP Business ByDesign all versions