Symptom
It is not possible to approve a customer invoices due to the error: An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Select customer invoice XYZ which is in status Not Released (XYZ represents the invoice ID).
- Open customer invoice XYZ and go to the Approval process tab.
You notice the error: "An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator"
Cause
Customer invoice XYZ was created with the status Not Released before the Approvals on Manual Customer Invoicing was scoped. Before enabling the approval process feature, you need to ensure that no manual customer invoices and credit memo documents are in status Not Released.
Resolution
This is the expected system behaviour.
See Also
Help center document: Approval for Manual Customer Invoice and Credit Memo
Keywords
KBA , AP-CI , Customer Invoice Processing , How To