Symptom
You have replicated Registered Products along with Start and End Date (Warranty Details) from ERP to C4C but no warranty details are getting replicated.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to Installed Base WorkCentre.
- Go to Registered Products View.
- Show All and find required ID, which are replicated from ECC to C4C.
- Select and Open it.
- Navigate to Overview, scroll down to section Warranty.
- Here you can find that no details such as Start Date and End Date is replicated.
Interface Used :RegisteredProductReplicationInitiatedByExternalIn
Cause
The Warranty Start and End Date is calculated based on reference date of the registered product, (this becomes warranty start date) and the duration (Warranty End Date = Start date + Duration).
In the Standalone scenario of Registered Product you can maintain a warranty in C4C with details such as warranty duration etc. and this warranty can be used in a Registered Product .This warranty is then also considered in subsequent processes such as Service ticket.In this warranty Start/End Date is not editable.
In ERP integration scenario, it is possible to replicate the master warranty from ERP to C4C even though this ERP warranty does not exist in C4C. The reason you cannot see the warranty is because it is hidden field by default .In this scenario the warranty Start/End Date also is editable and come from ERP .This Warranty is not considered in Service Ticket because the corresponding warranty does not exists in C4C.
Resolution
In order to see Warranty Details replicated from ERP, follow below given steps :
- Go to Installed Base WorkCentre.
- Go to Registered Products View.
- Show All and find required ID, which are replicated from ECC to C4C.
- Select and Open it.
- Navigate to Overview, scroll down to section Warranty.
- Go to Personalize and make field External Warranty ID visible.
- Perform Save.
Keywords
Not Replicate, Warranty Details, ERP to C4C, Registered Product , KBA , AP-IBA-IBA , Installed Base , How To