Symptom
Quiz settings are configured to limit the quiz attempts allowed, however the user is able to continuously launch the item's quiz regardless of number of attempts and/or completion status.
Environment
SAP SuccessFactors Learning - all supported versions
Reproducing the Issue
- View the Settings of a quiz (Learning Admin > Content > Quizzes).
- Set the Quiz Attempts Limit to a value higher than 0.
- Save Changes and Publish the quiz.
- Assign the Quiz to an Item (Item > Related Menu > Online Content > Add Quiz).
- Configure the quiz options to record learning events when quiz is both passed and failed.
- Modify the Settings (Settings dropdown menu > Modify Settings).
- Set the completion statuses for both Completion and Failure.
- Check the box for Content is available for launch.
- Assign the item to learning users.
Learning user's who fail the quiz more times than the Quiz Attempts Limit are able to launch the quiz again if the content window was closed when the Quiz Attempts Limit was exceeded.
Cause
Only the quiz is configured with a maximum limit, not the item's content object.
Resolution
Set the Failure Action status and enter the number of times user can fail before the action occurs.
- Modify the Settings (Item > Online Content > Settings).
- Check Add History on Failure.
- Select Failure Status and "Upon Failure".
- Once you select "Upon Failure" you will get option: "Number of Failed Attempts Allowed for an Item".
- Enter a value for "Number of Failed Attempts Allowed for an Item" and Ideally, this should match the value set for Quiz Attempts Limit.
- Save Changes.
- Assign the item to learning users.
If the learning user exceeds the Quiz Attempts Limit then the item is locked or removed from their learning plan.
Keywords
Upon Failure, Number of Failed Attempts Allowed for an Item , Failure Status , KBA , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , LOD-SF-LMS-CNT , Content , Problem