Symptom
In Basic search for Visits, results are returned only when the Visit Description is given, while showing any of the "My" queries. To search using any other field like Account Name, the user is expected to use the respective field in Advanced search.
However, in case the OWL is showing All Visits, the Visits can be queried using Account Names in the Basic search itself.
Reproducing the Issue
- Go to Visits work center.
- Go to Visit view.
- Select predefined Query My Open Visits.
- From the list of such visits, note the customer name of any one.
- Supply the name in the Search box.
- Return the search.
Results: No records found.
On the other hand,
- Go to Visits work center.
- Go to Visit view.
- Select predefined Query All.
- From the list of such visits, note the customer name of any one.
- Supply the name in the Search box.
- Return the search.
Results: All visits for the menitoned customer.
Cause
The feature under "All" queries is not enabled for the "My" queries in Visits.
Resolution
This is current system behavior. We plan to refine the same in a future release.
Keywords
KBA , LOD-CRM-ACT-VST , Visit Planning , How To