Symptom
In Integration Center (starting in 2017), the Job threshold limit by default, has been set to 25 jobs per day, which in turn increases the CPU performance.
Our engineeering have increased the default limit to 50 jobs per day from the Release 1H 2019 onwards.
After the 1H 2019 Release, to schedule more than 50 jobs per day, you must report a new case with SAP SuccessFactors Support.
Environment
- SAP SuccessFactors HCM Suite
- Integration Center
Reproducing the Issue
This issue can be reproducible in the Integration Center with more than 50 concurrent scheduled Jobs.
Cause
This threshold was set by SAP to increase CPU performance.
Resolution
Customers that need more than 50 scheduled Jobs in integration center should open an case in the LOD-SF-INT-INC component with below detail:
- What are the total number of employees?
- What is the expected increase in the number of daily jobs?
- Is there a possibility that they schedule the current daily jobs for a longer frequency (Ex: Weekly)?
- How many of these integrations are extracting full data and how many of these will extract delta records?
- Give examples of their existing/new use cases of daily runs.
- What is the approximate number of records being extracted per scheduled execution of the integration?
- Example of the API's/Entities being used to in case of extracting full data.
- How long will you need this increase for? (please specify, "Permanently", or time period in months e.g. "two months")
- If being requested as a permanent change, why is this?
- If being requested as a temporary change (e.g. "two months"), why is this? (e.g. company acquisition)
- Please explain shortly what are the business requirements for this increase.
- Please share your SF Company ID where you need this. Is this a Production instance or Test/Dev instance?
- What is the current threshold limit?
- Are you using multiple schedule per day feature for delta integrations?
- Approximate time taken by a job to complete in case of full load and delta load?
This parameter should be changed by SAP support team ONLY under Company Settings in our backend system based on the feedback received from our engineering team
(@ SAP Support colleagues, please review the Internal Memo on this KBA for additional instructions).
IMPORTANT NOTES:
1) The Integration Center Job Requests Scheduling Threshold can only be increased on a step-by-step basis (i.e. one level up at a time). For example: if your current threshold limit is set to 50, you can only increase it to the next step, which is 75. You won't be able to skip one step, for example increasing it from 50 to 100. The reason for this is that resource consumption / utilization is closely monitored by our internal teams.
Requests to increase multiple steps will not be considered (steps outlined below):
- 50 (default)
- 75
- 100
- 150
- 200
- 250
- 300
- 400
- 500
2) There can only be 5 jobs that can run max hourly (Multiple executions per day) - Integration center tool is not meant for scheduling jobs to achieve real time integrations. To achieve such a real time integration, please consider using events via the Event Hub or a middleware instead.
3) Any threshold change must be approved by the SuccessFactors Engineering Team. Please note these requests are normally assigned as a "P3 - Medium" priority case. If there is a more urgent priority required, please provide a detailed 'Business Impact', so Support and Engineering can assess the priority requirement.
Keywords
Job threshold, Integration Center, default 25 jobs per day, default 50 jobs per day, Job threshold limit, Job, limit, SuccessFactors, IC , KBA , LOD-SF-INT-INC , Integration Center , LOD-SF-INT , Integrations , How To