Symptom
Connector results in failure with the following message. Please note the bulk of the error message has been removed for operational reasons but the main error message is:
com.plateausystems.connector.api.ConnectorException: com.plateausystems.connector.api.ConnectorException: Problem retrieving files from FTP - checksum failed
Caused by: com.plateausystems.connector.api.ConnectorException: Problem retrieving files from FTP - checksum failed
Environment
SAP SuccessFactors Learning
SAP SuccessFactors HXM Suite
Cause
The Connector URL SFTP configuration is the old SFTP URL.
OLD: SFTP[number].SUCCESSFACTORS.COM e.g. SFTP8.SUCCESSFACTORS.COM
NEW: SFTP[number].SAPSF.COM e.g. SFTP8.SAPSF.COM
Resolution
The SFTP URL needs to be changed in the Connector Configuration file under:
- Navigate to System Administration > Configuration> System Configuration> CONNECTORS
- Search for the line connector.ftp.server
- Change the URL
- Click Apply Changes
If you are using either User Connector - SF or Competency Connector - SF then please contact your Implementation Partner or the Customer Support team via an case and ask them to check the SFTP URL in the BizX Backend Job Configuration (Provisioning).
Please keep in mind that old SFTPs from DC2, DC4, DC10 and DC12 still didn't have the URL changed, so if the issue happens, it needs to be checked by Customer Support via an case.
Keywords
checksum failed, Problem retrieving files from FTP, User Connector - SF, Competency Connector - SF , KBA , LOD-SF-LMS-CON , Connectors , LOD-SF-LMS , Learning Management System , Problem