SAP Knowledge Base Article - Public

2430188 - While Accessing Manage Career Site Builder, Source Tracker or Advanced Analytics the System Redirects to the Home Page - Recruiting Marketing

Symptom

  • While accessing the Manage Career Site Builder from Admin Center, users will encounter behavior where the system will attempt to load Career Site Builder (CSB) but then they will be redirected to the BizX Home Page.
  • Users may also encounter being redirected to the BizX Home Page when trying to access Source tracker and Advanced Analytics.

Environment

SAP SuccessFactors Recruiting Marketing (RMK)

Reproducing the Issue

  1. Access the Bizx instance
  2. Go to Admin Center
  3. Search for Manage Career Site Builder in the Tool search
  4. Click Manage Career Site Builder
  5. The system redirects the user to the Bizx Home Page

Cause

There are some possible causes for this issue:

  • The permission has been granted but the user is not synchronized yet because the Recruiter Sync runs once a day.
  • The user's e-mail address is mapped to another BizX user and the RMK system will not accept duplicate e-mail addresses. Due to this the user's data from BizX system is not synchronized to RMK system and hence the user cannot access Career Site Builder from Admin Center (BizX system); Please note that this behaviour will change with the 1H2024 release, when email addresses are no longer required to be unique for Recruiting users to be able to access CSB or Source tracker or Advanced Analytics.
  • The user does not have an email address populated in the system. (recruiter sync will mark this user as "ignored")
  • There was an instance refresh and the Security Key in Provisioning wasn't restored properly.
  • The URLs are not filled in provisioning. Provisioning / Configure Recruiting Marketing Datacenter URL / RMK Portal URL and RMK Job Search URL were empty
  • There's an error in the Recruiter Sync or Recruiter Sync is not enabled in CSB.

Resolution

In order to check the missing email addresses, refer to the steps below:

  1. User has to make sure that his/her e-mail address is present in the UDF file and not being used by other BizX users (can be checked by performing an Employee Export). Please note that this behaviour will change with the 1H2024 release, when email addresses are no longer required to be unique for Recruiting users to be able to access CSB or Source tracker or Advanced Analytics.
  2. Once the email address is populated, when the Recruiter SSO runs next time his/her BizX data will be synchronized to the RMK system and he/she will be able to access Manage Career Site Builder from Admin Center (and/or Advanced Analytics/Source Tracker).

In case the issue persists, please contact your Implementation Partner to review the configuration.

For Partners Only:

  • The user's e-mail address is mapped to another BizX user and the RMK system will not accept duplicate e-mail addresses. Due to this the user's data from BizX system is not synchronized to RMK system and hence the user cannot access Career Site Builder from Admin Center (BizX system): Partners can check if the user is duplicated in Command Center > Export Automated Process Logs. Please note that this behaviour will change with the 1H2024 release, when email addresses are no longer required to be unique for Recruiting users to be able to access CSB or Source tracker or Advanced Analytics.
  • The permission has been granted but the user is not synchronized yet because the Recruiter Sync runs once a day:
    • Partners can run manually the "sync all external job postings' in Provisioning
  • The user does not have an email address populated in the system. (recruiter sync will mark this user as "ignored")
    • Partners can check in Command Center > Export Automated Process Logs if there's any ignored user
  • There was an instance refresh and the Security Key in Provisioning wasn't restored properly.
    • Partners can re-apply the Security Key under Provisioning > Recruiting Marketing Settings
  • The URLs are not filled in provisioning. 
    • Partners can correct it in Provisioning > Configure Recruiting Marketing Datacenter URL > RMK Portal URL and RMK Job Search URL. Please refer to the correct information in the Recruiting Implementation Guide.
  • Make sure Recruiter Sync is enabled in CSB and check errors in Recruiter Sync, under Command Center > Export Automated Process Logs:
    • NullPointerException: Cannot invoke "com.jobs2web.common.util.TokenRequest.toString()" because "tokenRequest" is null: Please refer to KBA 3389485
    • NullPointerException: while trying to invoke the method java.lang.String.equals(java.lang.Object) of a null object returned from com.jobs2web.users.utils.recruitersync.AtsRecruiterWithPersonUuid.getPersonUUID(): Please refer to KBA 2891760

Keywords

RMK, RCM, Recruiting, Marketing, Reload, Homepage, CSB, AA, Advanced, Analytics, Redirect     , KBA , LOD-SF-RMK-ADM , Administration, Setting, Permissoin & RBP, RecruiterSyn , LOD-SF-RCM-CSB , Career Site Builder , Problem

Product

SAP SuccessFactors Recruiting all versions