SAP Knowledge Base Article - Public

2431413 - [SF MOB] - Mobile Apply Framework does not allow Candidate to complete Job Application on RMK Career Site when using a Mobile Device

Symptom

Candidate repeatedly provides email address when applying for a job using a mobile device but cannot proceed to next step as the system is stuck on a loop.

Environment

  • SAP SuccessFactors Recruiting Management
  • SAP SuccessFactors Recruiting Marketing
  • SAP SuccessFactors Mobile

Reproducing the Issue

  1. Open the RMK career site on a mobile device.
  2. Search for a job and click on apply now.
  3. Provide email address and click on "Start" button.
  4. Nothing happens. Candidate sees the same page again where he needs to provide the e-mail id while applying.

Cause

The configuration is not correct with respect to Mobile Apply.

  1. “Mobile Version (Legacy)" is enabled.
  2. “Use business card apply for mobile (Standard & Responsive)" is not enabled.

Resolution

For a seemless apply workflow froma mobiel device the following settings must be set in the CSB site settings:

  • Legacy Mobile – set to OFF
    <mobileversion>false</mobileversion>

  • On-Page Business Card - set to ON
    <useonpagebusinesscard>true</useonpagebusinesscard>
  • Use Business Card Apply for Mobile (Standard & Responsive) - set to ON
    <usemobiletc>true</usemobiletc>

These settings can now be checked and changed in Career Site Builder.

  1. Go to CSB > Tools > Import & Export > Export tab;
  2. Export the Site Settings twice (important note: keep two copies of this file - one unmodified as a backup in case anything goes wrong so you can restore the original configuration, and one that you will modify);
  3. Open the file you will be modifying with a text or XML editor (e.g. Notepad++, Oxygen, etc...);
  4. Modify the settings in the XML file as outlined above
  5. Save the file;
  6. Go to CSB > Tools > Import & Export > Import tab;
  7. Import the Site Settings using the modified file;
  8. Reload the page

See Also

2331658 - A larger screen is required on mobile apply

Keywords

Mobile apply, Unable to apply, External Site, CAS, Mobile Device , KBA , LOD-SF-RMK-ADM , Administration, Setting, Permissoin & RBP, RecruiterSyn , Problem

Product

SAP SuccessFactors Recruiting all versions