SAP Knowledge Base Article - Public

2432395 - JDBC error when two email types are provided in New Hire wizard

Symptom

Could not execute JDBC batch update error message when submitting new hires with two email types provided in Email Information

JDBC error NHW.png

Environment

  • SAP SuccessFactors Employee Central 1608 and above
  • v12 / People Profile (PP3)

Reproducing the Issue

1. Go to Admin Center > Add New Employee to add a new hire into the system.

2. Provide information on required fields and add personal email in Email Information section.

3. Go through the remaining steps then submit the new hire. The error message below is thrown by the system:

Sorry, an error occured during the recruitment process.

Wrapped Exception: Remote exception: HibernateException thrown Could not execute JDBC update; nested exception is: com.successfactors.db.dao.DAOException: HibernateException thrown Could not execute JDBC update

Product Support: Please see internal memo for log example

Cause

Employee Information base object currently does not support business rules for email information

Resolution

This is a currently a product limitation on business rule base objects that is targetted to be fixed in future releases. In the meantime, use Email Information as the base object for all business rules assigned on emailinfo element.

Keywords

JDBC error, Wrapped exception, Remote exception, HibernateException, Email Information, business rule, new hire, ECT-61725 , KBA , LOD-SF-EC-CMP-RUL , Business Rules , LOD-SF-EC-HIR-NEW , Add New Employee Wizard , Problem

Product

SAP SuccessFactors Employee Central 1611 ; SAP SuccessFactors Employee Central 1702 ; SAP SuccessFactors HCM Core 1608