SAP Knowledge Base Article - Public

2432535 - Updates in the Candidate Profile are not synced in the Application - Recruiting Management

Symptom

When candidates update their personal information such as phone or email in their candidate profile, the information is not updated in the application.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Candidate applies to a job;
  2. Advance application in pipeline;
  3. Candidate updates his/her profile;
  4. Changes in the candidate profile are not synched in the application.

Cause

When a candidate initially applies to a job the data from the Candidate Profile is synchronized to the Application. In this case, the data of the application is a snapshot at that specific time. Subsequent updates to the Candidate Profile will not update the data in the Application.

Resolution

Possible solutions for scenario:

  • Enable multi-stage application, add a status in the pipeline (e.g. candidate pre-boarding update) and grant permission for candidates editing contact information fields such as address, phone number and etc. Note that to enable multi-stage application, you will need to contact an implementation partner or SAP Professional Services to provide analysis, recommendations and start implementation project.
  • In order to enable the editition of the candidate profile snapshot refer to the KBA 2081624- Edit Candidate Profile Snapshot - Recruiting Management.

See Also

2081624 - Edit Candidate Profile Snapshot - Recruiting Management
2397128 - Synchronisation between Candidate Profile and Application - Recruiting Management

Keywords

Updates in the Candidate Profile are not synced in the Application, Recruiting Management, RCM, update application profile, candidate profile update, candidate profile synchronization, application is not synced   , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions