SAP Knowledge Base Article - Public

2432707 - Error Message: "External Key, XXXXX Does Not Exist" While Linking the Contacts With the Accounts Using Data Workbench

Symptom

You have uploaded Accounts with External Keys and Contacts with External Keys respectively using Data Workbench. Your requirement is to link Contacts with Accounts using the respective External Keys using Data Workbench. But after Import, the file has Completed with Processing error:

External key, XXXXX does not exist.

*XXXXX represents the External key

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Data Workbench work center
  2. Select Import
  3. Select the Object Account Contact Relationship
  4. Select Next
  5. Upload the template
  6. Select Import
  7. In the Monitor tab, check for the respective Task ID
  8. The records in the file have the Processing error

Cause

The Contacts file when uploaded with External Keys contains the column ExternalKey which was renamed to YYYYY (where YYYYY is the Column header). If the column is renamed, system requires manual mapping on the Mapping screen.

Since mapping was missed, the Contact records got created without External Keys. Therefore, system throws an error while linking the Accounts with Contacts.

Resolution

Once the columns are renamed, manually maintain the mapping on the Mapping screen during the Data Workbench activity.

Note:

You need to review the mapping before proceeding to Import step.

Keywords

External key does not exist, External Key, ExternalKey , KBA , external key does not exist , externalkey , external key , LOD-CRM-INT-DWB , Data Workbench , How To

Product

SAP Cloud for Customer add-ins all versions