Symptom
Quantity fields are missing from the Service Ticket template in Data Workbench.
Examples: Planned Quantity, Actual Quantity, Planned Start Date & Time, Actual Start Date & Time.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Select the Odata Services view.
- Select the service: yserviceticket.
- Search for any of the fields: Planned Quantity, Actual Quantity.
You are not able to locate these fields.
Cause
Service Request entity has been included in the standard C4C OData API – c4codata. Hence, you are requested to use that instead of yserviceticket.
Resolution
The Start Date time fields are not part of the standard service.
Therefore a custom service would need to be built where these fields can be selected:
- FirstRequested - stands for Planned Quantity.
- FirstFulfilled - stands for Actual Quantity.
Keywords
yserviceticket, Planned Quantity, Actual Quantity , KBA , LOD-CRM-EMP , Employee , How To