SAP Knowledge Base Article - Public

2435958 - Data Workbench : Missing Quantity Field in Service Ticket Template

Symptom

Quantity fields are missing from the Service Ticket template in Data Workbench.

Examples: Planned Quantity, Actual Quantity, Planned Start Date & Time, Actual Start Date & Time.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Select the Odata Services view.
  3. Select the service: yserviceticket.
  4. Search for any of the fields: Planned Quantity, Actual Quantity.

You are not able to locate these fields.

Cause

Service Request entity has been included in the standard C4C OData API – c4codata. Hence, you are requested to use that instead of yserviceticket.

Resolution

The Start Date time fields are not part of the standard service.

Therefore a custom service would need to be built where these fields can be selected:

  • FirstRequested - stands for Planned Quantity.
  • FirstFulfilled - stands for Actual Quantity.

ServiceTkt_Odata.PNG

Keywords

yserviceticket, Planned Quantity, Actual Quantity , KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer add-ins all versions