Symptom
When entering termination details for employee, and pressing submit, an application error appears.
An application error also appears when navigating to the affected users Time Off UI.
This is only occurring for some users.
Environment
Employee Central, Time Off
Cause
The null pointer is caused by a data issue.
At least one of the time accounts for the involved users has at least one time account details with bookingAmount = null.
During the termination process, the time account balance is calculated for the terminated users.
To do that, all the booking amounts of all the time account details on the account are summed up.
The null value causes this process to fail. This is not supposed to happen as the bookingAmount is a required field in MDF and therefore should never be null in the first place.
Support: See internal memo
Resolution
To fix the issue:
- Export and look at the time account details on the time accounts of the affected users.
- Look for any entries where the bookingAmount = Null.
- Add the correct amount via Manage Data > Time Account > Take Action > Make correction > Select Details, and enter a value for the required field "Amount Posted" . 0 is allowed.
Keywords
ECT-68799
Application error
Termination , KBA , LOD-SF-EC-TIM , Time Off , Problem