Symptom
The SSO is not working when connecting from Analysis Office to HANA system via OLAP connection defined in BIP/CMC.
The trace contains the following entries when trying to access HANA (http(s)://<server>:<port>/sap/bc/ina/service/v2/GetServerInfo):
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The remote server returned an error: (500) Internal Server Error.
at System.Net.HttpWebRequest.GetResponse()
at com.sap.ip.bi.pioneer.core.connections.CrHttpConnection.GetResponse(HttpWebRequest iRequest, String purpose)
at com.sap.ip.bi.pioneer.core.connections.CrHttpConnection.Connect(String iUser, String iPassword, String iTicket)
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Environment
SAP Analysis for Microsoft Office
Cause
The issue may occur because the SAML Service Provider name (in HANA side) is not the same as the Service Provider Name defined in BIP/CMC.
Resolution
Make sure that the SAML Service Provider name (in HANA side) is exactly the same as the Service Provider Name defined in BIP/CMC. These two fields (shown below) must be the same:
Screenshot showing the configuration in CMC/BIP side
Screenshot showing name of Service Provider in HANA side
Keywords
saml, sso, single, sign, on, single-sign-on, automatic, authentication, logon, prompt, dialog, user, unable, configuration, configuring, hana, db, login, olap connection, xs, serviceprovider , KBA , BI-RA-AO-CON , Please use component BI-RA-AO-XLA , BI-RA-AO-XLA , Excel Addin , Problem